欢迎关注:1,欢迎关注本博客,你可点击右手边的【QQ邮件订阅】订阅本博客!2,本博客推出江湖救急计划,主要为工作中遇到疑难杂症的兄弟提供远程技术支持和分析,如有需要,请在江湖救急计划页面给我留言!

某省厅门户网站A市局访问异常应急处置

作者:竹林再遇北极熊 发布于:2017-11-28 21:47 Tuesday 分类:网络分析

1 情况概述

1.1  网络拓扑结构

    梳理省厅网络拓扑结构,了解WEB服务器通过接入交换机、WAF、抗D,经防火墙对外映射对外提供服务,其中交换机、抗D、WAF均为二层部署,如下图所示


1.2 情况简介

    A市局近期有无法访问省厅门户网站的现象,换个IP即可正常访问,与省厅沟通后发现其他市局和互联网用户均能正常访问。

1.3 分析思...

阅读全文>>

标签: 日志 交换机 TCP wireshark 负载均衡

评论(1) 引用(0) 浏览(1038)

如何保证IT服务的质量?

作者:易隐者 发布于:2013-2-5 21:29 Tuesday 分类:IT 服务

       IT服务涵盖的范围非常广,其可以是一个具体产品的售后服务,如给用户提供一台设备后的安装与实施,也可以是一个专门的IT服务产品,如各种IT外包服务等。
       IT服务不像那些具有具体、明确交付物的产品,我们可以根据产品的形态、功能、性能等特性来衡量其质量如何,比如我们提供给用户的硬件产品,我们可以通过硬件产品的相应配置和性能指标对其进行比较和衡量,从而得出该产品是否符合用户的要求或需求的结论,这很容易实现,双方也都容易理解。但是IT服务的最终成果往往是无形的并且难以衡量,那么针对这些IT服务,我们如何保证这些IT服务的质量是足以让用户满意的?个人总结如下图所示:
 点击查看原图
以用户/客户为中心
       我们提供的IT服务是面向用户/客户的,因此,我们所谓的IT服务质量肯定是以用户/客户的体验和感受为依据,说白了就是用户说你的服务很好,就说明用户认可你的服务,那么服务的目标基本上就达到了,自然就可以认为我们提供的服务质量是令用户满意的。
       用户可以根据其感受对IT服务的质量进行评价,但是用户的感受具有很大的主观性,因此我们首先要做的就是在主观上:围绕客户而做好以下几点:

1, 维护良好的客户/用户关系

       在中国现在的大环境下,一提到“用户关系”,很容易让人想到通过行贿受贿等潜规则换取的交易型用户关系,但我在这里提到的“用户关系”并不是指这种类型的用户关系,而是指通过对用户的尊重、站在用户的角度去考虑问题、积极主动的帮助用户解决问题、成为用户核心业务支撑上的强大后盾等多种方式建立起来的真正意义上的用户关系。这种用户关系建立在真实、平等、互信、互惠互利的基础上,这种更为稳固的用户关系能够大大提高用户主观上对IT服务质量的认可度。当然良性优质用户关系的建立并非一日之功,需要服务团队的每个成员为这种良性关系不断添加正面的积累,通过较长的时间方能逐步建立。

2, 服务态度

       用户关系是长期而持久的,而服务态度则具体至每一次的服务过程。建立、维护用户关系过程中非常重要的一点就是服务态度,对服务态度的要求并非IT服务行业的特例,所有的服务行业基本上都是一样的,具体主要有以下几点基本要求:
       热情:对用户热情,有问必答,不可爱理不理,没精打采,心不在焉
       诚恳:对用户诚恳,坦诚相待,特别是在服务过程中出现失误和损失时
       积极主动:主动帮助用户提供解决问题的方案,多做一些本职工作分外之事,解决用户的问题,满足用户需求。

       在某些技术含量不高的服务工作过程中,态度对服务质量的影响远远超出服务过程本身,举一个简单的例子,在用户不紧急、对用户影响不大的IT环境中,即使提供服务的工程师经验和水平有限,但是在其热情、诚恳端正的服务态度下,用户也不会太责难他,甚至有用户会安慰工程师,给他足够的时间,帮助他协调各种资源来尽快解决遇到的问题,最终虽然解决的时间比预期的长,但用户对服务质量的主观感受也不会很差,这就是良好的服务态度从中起到的作用。当然,在IT服务这个高技术含量的工作中,这个例子不会是一个普遍的现象,但足以说明态度是做好IT服务的第一步,这一步迈不好,所谓的服务质量就无从谈起。

3, 沟通并与用户达成一致

       主要针对验收标准、免责条款达成一致性意见。
       服务的特性决定了其没有直观的、统一的质量验收标准,标准不一是造成验收异议的根源,而一旦用户对服务结果存在异议,对服务质量的影响将不言而喻,严重时,可能会直接导致IT服务不被用户认可,直至整个IT服务工作的失败。另一方面,信息系统的构成是非常复杂的,与用户核心业务系统的正常运转关联的因素非常之多,有时并不是一次性的IT服务就一定能够解决的,可能需要升级其他的IT服务项目或购买相应的设备才能解决,一旦出现这种情况,如果不提前说明清楚并得到用户的认可,事后难免出现分歧。因此,我们应该在提供IT服务之前与用户做全面的沟通和交流,一起就IT服务产品的验收标准和免责条款达成一致意见,并签署相应的IT服务合同。

       考虑到用户只关心最终结果而无须关心具体实现细节以及IT服务的专业性,我们一般主要针对IT服务的实施效果作为IT服务的验收标准,比较常见的衡量指标有服务响应时间、网络恢复时间、业务恢复时间、服务完成时间、一次性问题解决率等等。

       虽然用户的主观感受在衡量IT服务质量的过程中非常重要,但是由于IT服务高技术含量的特性以及信息系统对用户的重要性,IT服务质量的根本还在于我们能够提供的服务能否高效、经济的解决用户的问题,这就要求IT服务提供者在客观上从如下几点做好自己:

1, 专业能力

       IT服务高技术的含量特性要求提供IT服务的人员必须具有一定的专业水准,提供具体服务的工程师的专业技术能力水平决定了我们为用户提供的服务所能达到的效果。

      一般而言,技术能力更强的工程师总能提供更好的IT服务过程、质量保证,更容易达到令用户满意的服务效果,同时技术能力更强的工程师会产生更高的服务成本,考虑到服务的经济性,我们需要将用户的服务类型和工程师能力水平进行合理的划分,以便我们为用户提供低成本、高质量的IT服务。除了服务团队的梯度划分,我们还必须建立一支专家团队作为强大的技术服务后盾,随时应对服务过程中遇到的各种疑难问题和突发事件,以保证绝大部分的服务质量不会受到小概率突发问题的影响。
       IT服务提供者对IT服务团队成员内部的选拔、培训、淘汰、激励等种种制度是保证IT服务团队具备高超专业技术能力的基础。这涉及到整个服务团队的建设问题,是一个大课题,在此就不做过多的阐述了。

无强大的专业技术能力,服务质量无法保证。

2, 标准流程

       这里的标准流程主要指服务的标准流程和内部的工作流程两方面。
       绝大部分的服务的流程都是可标准化的,服务流程标准化的好处是其可以大大减少服务质量的偏差,我们试想一下,如果甲工程师按照其个人的习惯为用户提供某个IT服务,乙工程师也按照自己的一套方式为用户提供IT服务,即使甲乙两人最终都可以完成各自的IT服务过程,但是整个服务质量却会因个人的经验、技术能力、工作习惯等差异的影响而出现较大的偏差,这些都是影响IT服务质量的不可控因素,服务流程标准化之后,提供具体IT服务的人员全部按照标准化的服务流程按部就班的为用户提供IT服务,可以大大减少这些不可控因素对服务质量的影响。经过不断完善的标准化的服务流程还可以大大提高服务的效率,让经验不足的工程师在提供服务的过程中少走弯路。

       另一个标准流程主要指IT服务团队内部的工作流程标准化,包括IT服务请求的受理、服务过程的状态监控、状态通告、服务升级、服务评价、投诉等等。

3, 检验考核

       为用户提供的每个具体的IT服务都应该在经过检验后纳入服务团队内部考核之中。针对服务质量的检验主要指用户检验和内部检验两种,用户检验可包含对服务提供者的服务态度、主动性、专业性等多方面给出评价,内部检验则从用户的反馈、服务的交付物等方面对其服务过程和质量作出检验。

将用户对服务过程的检验反馈和内部对服务质量的检验结果作为团队内部考核的内容之一,这样做的目的是督促具体的IT服务人员,鼓励其主动做好IT服务工作,提高IT服务的质量和用户的满意度。

4, 交付物

       绝大部分的IT服务是无形的,不像有形的IT产品那样,用户可以清清楚楚的看到他的机房里放着一台服务器、交换机、防火墙,因此IT服务作为一个无形的产品,我们需要将服务的成果实体化、具体化,最为常见的形式就是服务文档。我们在每一次提供IT专业服务之前就应该告知服务后会有哪些交付物交给用户,这些交付物大部分都是服务文档,这些文档主要包含所提供的专业服务的完成情况、给用户带来的可评估效果、给用户的改进优化建议、解决方案等等不一而足,一般根据具体的IT服务类型提供不同内容的文档,这个需要结合服务团队的服务目录做专门的文档架构、设计和规划。

       服务文档交付物让用户直观的感受到IT服务的价值,同时也是体现服务专业性的一种方式,另外有些服务文档还可以作为服务团队内部的知识库。在专业的IT服务产品中,交付文档是不可或缺的,我们需要认真细致的对待每一个服务之后递交给用户的交付文档。

总结

       IT服务的质量保证工作应该以用户感受为中心,态度为基本门槛,专业能力为基础,内部管控为根本,外部关系为升华。通过不断的完善与加强,在上述主客观、内外部的因素之间形成良性循环,不断提升IT服务的质量和用户的满意度。

阅读全文>>

标签: 解决方案 交换机 团队 响应时间 团队成员 服务质量保证 交付物 IT服务

评论(2) 引用(0) 浏览(3315)

【转】交换机端口镜像,如何配置多个观察口

作者:易隐者 发布于:2012-12-27 12:40 Thursday 分类:参考资料

 

【说在之前】:

1,H3C和华为等多系列交换机均不支持多组镜像和多镜像监听口,这给有IDS、审计、网络分析等多种需要通过镜像采集流量的设备环境造成了诸多不便;

2,前段时间刚在用户故障现场发现有人使用交换机内回环巧妙实现了在H3C交换机环境下的多个监听采集需求,回来后一直想把这个方法写下来,只是在网上找了非常多的资料,均未有详细的说明,便耽搁下来,没想到今天就有人把这种方法整理了出来,实在巧合,正好转载于此,供大家参考;

3,这种镜像的方式,是否会导致报文被多次重复捕获?这是一个有待验证的问题,因为我们上次在用户现场发现通过这种方式镜像捕获的报文中有许多是重复捕获的,有试验环境的兄弟可以做一个详细的实验,拿出来供大家分享。

【原文连接】:

   http://support.huawei.com/ecommunity/bbs/10152503.html

【原文作者】:

   huang8880

【原文全文】:

实现原理:将所有端口镜像报文引入一个观察端口,通过观察端口内部环回(配置loopback internal),将报文在vlan内广播道其它若干实际观察端口,报文出端口时剥除vlan id

配置举例:

预留vlan3500for example

#
vlan batch 3 10 20 100 300 to 301 3000 to 3002 3500 4000
#

观察端口

#
observe-port 1 interface GigabitEthernet0/0/21 vlan 3500
#

三个镜像端口:

#
interface GigabitEthernet0/0/3
port-mirroring to observe-port 1 both
#
interface GigabitEthernet0/0/4
port-mirroring to observe-port 1 both
#
interface GigabitEthernet0/0/5
port-mirroring to observe-port 1 both
#

三个观察端口:

#
interface GigabitEthernet0/0/11
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 3500
#
interface GigabitEthernet0/0/12
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 3500
#
interface GigabitEthernet0/0/13
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 3500
#
环回端口:
#
interface GigabitEthernet0/0/21
description neibuhuanhui
loopback internal
mac-address learning disable
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 3500
stp disable


注意:如果交换机全局配置stp enable,需要在环回端口上配置stp disable,否则该端口如果接收到交换机自己发出去的stp报文,会将端口置为discarding状态,环回报文都会在入向被丢弃

阅读全文>>

标签: 端口镜像 交换机 环回接口 loopback

评论(0) 引用(0) 浏览(9330)

【转】上网认证页面无法打开案例

作者:易隐者 发布于:2012-11-25 10:40 Sunday 分类:案例讨论

【说在之前】:

1,该案例的确属于疑难故障范畴,若不是通过抓包方式,站在数据包交互的角度进行分析是无法定位、解决该故障的,因此,该案例具有学习参考价值;

2,案例的分析用到了关联分析法和对比分析法,思路非常清晰,但整个文档在图文编辑和措词这块还可以做进一步的加强,考虑到原文的完整性,我不对该文档做任何修改;

3,难能可贵的是作者在找到故障原因并解决故障之后,没有像大部分人那样将这个故障束之高阁, 而是将自己的分析思路、过程整理成文档,分享给大家,另外,发现其中难以解释的、存在疑问的地方,供大家一起讨论,这正是我一直倡导的“自我总结、无私分享、共同探讨、共同进步”的学习方式;

4,针对该案例后面的疑问,我就我的理解作出相关解答,供大家参考。

     针对第一个疑问:AC在此处工作在透明模式下,正常情况下其对报文的干预和处理根本不需要经过路由,也就是说,AC在做HTTP重定向的时候,根本不需要根据路由表,将这个HTTP重定向报文转发给PIX防火墙,而应该直接构造相应HTTP重定向报文发往核心交换机,因此,此处出现这样的问题,我个人认为如果AC是按照路由方式处理的话,其应该有相应的转发表,转发表中会有下一跳、转发接口等相关信息,而出现此案例中的问题,说明AC的转发表出现了异常,可能是其上联口和下联口是属于同一网段,而AC转发表未对其进行区分导致的;

     针对第二个疑问:这里需要明确,AC的管理口和业务口是否是完全独立的,如果是,那么所谓的两条默认路由是完全分开的,没有任何问题,如果不是,那么根据不同的系统处理方式,负载均衡(根据报文或其他)或者选择其中一条都是有可能的,多年前我曾写过一篇《供电局调度所前置机故障解决说明》的文档,就是两条默认路由导致异常的案例,过段时间我把这个案例共享到我的博客供大家参考。

5,该案例作者肖鉴为我以前推出《合肥网络分析技术团队招募学徒》的第一个学员。他不远千里从福建专程请假几十天跟随我学习相关知识,当我第一眼看到他时,我就被他的这种对技术执着追求的行为所感动,他基础不错,学习踏实认真,我个人认为我真正给他的帮助不在于具体技术的成长和进步,而在于影响他对技术的自信、清晰的职业发展方向规划以及行事的风格,在他身上我能看到我以前的影子,他现在深信服的总代,刚获得深信服深信服华南区技术大比武冠军,看到他的成长,我的内心是无比的欣慰。

【原文全文】

1. 网络环境

        故障网络环境如下图所示: 

点击查看原图

说明:
1. 出口防火墙工作在路由模式做NAT代理内网上网,E1口IP地址192.168.247.1/24。
2. 上网行为管理工作的网桥模式下,为其网桥IP地址配置192.168.247.3/24、网关IP地址为192.168.247.1用于设备管理,下联三层交换机IP地址为192.168.247.2/24。由于,前置PIX防火墙为阻止192.168.247.0/24网段上网,所以为了上网行为管理能够更新内置规则库,上网行为管理口下联三层核心交换机为其配置IP地址192.168.20.250网关IP地址192.168.20.1。
3.上网行为管理对内网部分网段实行认证上网。

2. 故障现象

       内网无须进行认证PC机访问互联网正常,需进行认证网段PC机上网在正常情况必须得先进行认证输入用户名和密码后方可访问互联网,故障表现为认证网段PC机无法正常跳转至认证界面输入用户名和密码。如下图所示: 

点击查看原图

3. 故障分析

3.1 常规分析

       在PC上访问网络时无法跳出登陆界页时,我们手动输入http://192.168.247.3认证登陆页面是正常,如下图所示,并且,输入完认证用户名和密码后可以正常访问互联网。说明网络中并不存在路由问题。那么是否可能是设备本身处理机制出现问题呢?还是,PC机与上网行为管理设备通信出现了其它的异常导致PC机无法正常弹出认证页面?。 

点击查看原图

阅读全文>>

标签: 交换机 团队 疑难故障 TCP 网络分析 负载均衡 抓包 深信服 上网行为管理 HTTP重定向 AC 路由表 转发表

评论(0) 引用(0) 浏览(9920)

交换机内部报文处理流程

作者:易隐者 发布于:2012-11-20 21:05 Tuesday 分类:参考资料

       交换机作为网络基础设施中不可或缺的组成部分,是最为常见的中间设备之一,其内部报文的处理流程如下图所示:

点击查看原图

       此图来自于互联网,仅供大家参考。

阅读全文>>

标签: 交换机 中间设备 报文 报文处理流程

评论(0) 引用(0) 浏览(4359)

Powered by 易隐者 基于emlog 皖ICP备12002343号-1